DHTMLET(TM)

苏昱作品·版权所有
©2002 Rainer Su . All rights reserved .


Rainer's Cascading Style Sheet 2.0 Handbook

Introduction To This Book关于此手册
手册说明：
    本手册是 Rainer's DHTML Library 产品的一部分。

    本手册针对的是已有一定网页设计制作经验的读者。其目的是提供完整清晰的样式滤镜的快速索引及进阶帮助。所以对于网页制作和样式表的基础知识，仅简单介绍，恕不赘述。
    本手册以浏览器的事实标准—— Internet Explorer 为主。
    手册中为所有的滤镜，除了基本的语法示范外，都度身制作了可以对照源代码即时察看运行演示的实例。
    本手册的升级信息与版权声明请参阅关于本书页面。
    本书中涉及到的所有HTML对象(Object，Element)，HTML属性(Attributes)和特性(Properties)请参阅我的相关著作。

如果您对本手册有什么疑问，或您有事想同苏昱联系，请：
    访问：http://www.rainersu.com 　　致信：rainersu@hotmail.com


Rainer's Cascading Style Sheet 2.0 Handbook

End User License Agreement最终用户许可协议
重要须知：
    本《最终用户许可协议》（以下称《协议》）是您（个人或单一实体）与苏昱之间有关苏昱之作品的法律协议。本作品包括计算机软件，并可能包括相关媒体、印刷材料，电子文档，图片。还包括对苏昱提供给您的原作品的任何更新和补充资料。您一旦安装、复制、下载、访问或以其它方式使用本作品，即表示您同意接受本《协议》各项条款的约束。如您不同意本《协议》中的条款，请不要安装或使用本作品。
协议条款：
    本作品受著作权法及国际著作权条约和其它知识产权法和条约的保护。
    本作品（包括但不限于本作品中所含的任何图象、照片、动画、录像、录音、音乐、文字和附加程序）、随附的印刷材料、及本作品的任何副本的产权和著作权，均由苏昱或相关作者拥有。
    本《协议》授予您下列权利：您可以安装、使用、访问、显示、运行本作品。您可以保留多份副本，可以自由传播本作品。
    上述权利不适用于您的任何商业行为或商业用途。否则您务必与苏昱联系。
    苏昱不为本"软件产品"做任何担保。本"软件产品"及任何相关文档以"即此"形式提供，无任何明示的或暗示的担保，包括（但不限于）对可销售性、适用性、或无侵权的暗示担保。使用本"软件产品"所引起的全部风险由您自己承担。
    本协议未明示授予的一切其它权利均为苏昱或相关作者所有。对于此处所指的其他权利，如篡改、反编译、改编、引用、拆解（破坏本作品原始完整性）等，同样请您务必与苏昱先行联系。
    如您未遵守本《协议》的各项条款和条件，在不损害其它权利的情况下，苏昱可终止本《协议》。如此类情况发生，您必须销毁本作品的所有副本及其所有组成部分。苏昱保留对本产品及本协议的最终修改权。

    本《协议》受中华人民共和国法律管辖。

如果您对本《协议》有什么疑问，或您有事想同苏昱联系，请：
    访问：http://www.rainersu.com 　　致信：rainersu@hotmail.com


关于 - Rainer's PicSchema

重要说明：
以下信息截至本文档发布之日止。最新个人信息请在 www.rainersu.com 查阅。
基本情况：
姓名： | 苏昱(Rainer Su)
性别： | 男
生日： | 一九七七年九月十四日
学历： | 小学
形象描述：
长发。麻花辫。为了省事买的都是灰黑色系的衣服。不上相。故照片和本人的观感有较大出入。
如果没被照片吓死或恶心死，建议看看本人。此段信息征女友用。
工作经历：
1996.07-2000.03 | 中国航空油料安徽分工司 (CAOSC) | 油品化验员
2000.03-2000.08 | 北京易得方舟信息技术有限公司 (www.chineseall.com) | 栏目主编 频道经理
2000.09-2001.05 | 上海榕树下计算机有限公司 (www.rongshu.com) | 网页设计 前台工程师
2001.05-2002.04 | 异联信息技术上海有限公司 (Erry) | 软件UI设计师 软件工程师
2002.04-? | 上海贝塔斯曼文化实业有限公司 (Bertelsmann) | 网站负责人
能力自述：
精通网络开发的客户端(前台)技术。专家级的网页技术和丰富的工作经验。
有参与实际大型商业软件产品开发的经历。
多篇小说、散文等发表于《青年作家》、《作家天地》等杂志。
独立开发过多种桌面应用软件产品。
联系方式：

    致信：rainersu@hotmail.com
    访问：www.rainersu.com

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - ©版权所有 苏昱(Rainer Su)，2002 | rainersu@hotmail.com - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -


filters版本：DHTML Object Model　数组集合
语法：
Scripting | oColl = object.filters
Scripting | oObject = object.filters ( vIndex , iSubIndex )
取值：
vIndex | : | 必选项。整数值(Integer) | 字符串(String) 如果此参数使用的是整数值，则返回数组中的整数序号等于此参数值的要素。如此参数值等于 0 则返回数组中的第一个要素。 如果此参数值使用的是字符串值，则返回数组中所有 name 或 id 属性等于此参数值的要素。假如符合条件的要素数目多于一个，则返回的将是一个数组。
iSubIndex | : | 可选项。整数值(Integer) 。 当 vIndex 参数值为 字符串时，数组中所有 name 或 id 属性等于 vIndex 的要素将被作为一个数组获取，而 此参数值便用于指定返回此数组中的整数序号等于此参数值的要素。
返回值：
oColl | : | 数组(Array)。返回作用于 object 的滤镜集合。
oObject | : | 对象(Object)。返回对被 object 包含的要素数组中的一个项目的引用。
说明：
获取作用于 object 的滤镜集合。


AlphaImageLoader兼容性：IE5.5+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.AlphaImageLoader ( enabled=bEnabled , sizingMethod=sSize , src=sURL )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.AlphaImageLoader ( sProperties ) "
说明：
在对象容器边界内，在对象的背景和内容之间显示一张图片。并提供对此图片的剪切和改变尺寸的操作。如果载入的是PNG(Portable Network Graphics)格式，则0%-100%的透明度也被提供。
PNG(Portable Network Graphics)格式的图片的透明度不妨碍你选择文本。也就是说，你可以选择显示在PNG(Portable Network Graphics)格式的图片完全透明区域后面的内容。
示例：
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.AlphaImageLoader(src='rain1977.gif',sizingMethod='scale');}
.dream{filter:progid:DXImageTransform.Microsoft.AlphaImageLoader(src='images/earglobe.gif');}


Gradient兼容性：IE5.5+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Gradient ( enabled=bEnabled , startColorStr=iWidth , endColorStr=iWidth )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.Gradient ( sProperties ) "
说明：
在对象的背景和内容之间显示定制的色彩层。
当此效果通过转变显示时，在渐变册色彩层之上的文本程序性的初始化为透明的，当色彩渐变实现后，文本颜色会以其定义的值更新。
示例：
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.gradient(enabled='false',startColorstr=#550000FF, endColorstr=#55FFFF00) ;}
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.gradient() ;}


Alpha兼容性：IE4.0+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Alpha ( enabled=bEnabled , style=iStyle , opacity=iOpacity , finishOpacity=iFinishOpacity , startX=iPercent , startY=iPercent , finishX=iPercent , finishY=iPercent )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.Alpha ( sProperties ) "
说明：
调整对象内容的透明度。
你可以设置整体透明度，或线性渐变和放射渐变的透明度。
示例：
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.Alpha(opacity=50);}
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.Alpha(opacity=10,finishOpacity=100,style=2);}


BasicImage兼容性：IE5.5+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.BasicImage ( enabled=bEnabled , grayScale=bGray , mirror=bMirror , opacity=fOpacity , XRay=bXRay )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.BasicImage ( sProperties ) "
说明：
用于色彩处理，图像旋转，或对象内容的透明度。
当此效果通过转变显示时，在渐变册色彩层之上的文本程序性的初始化为透明的，当色彩渐变实现后，文本颜色会以其定义的值更新。
示例：
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.BasicImage(opacity=.2); }
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.BasicImage(invert=1); }
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.BasicImage(invert=1,GrayScale=1); }


Blur兼容性：IE5.5+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Blur ( enabled=bEnabled , makeShadow=bShadow , pixelRadius=flRadius , shadowOpacity=fOpacity )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.Blur ( sProperties ) "
说明：
制作对象内容的模糊效果。
示例：
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.blur() ; }
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.blur(pixelradius=3.0, makeshadow='true', ShadowOpacity=1.0); }
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.blur(pixelradius=3, enabled='false') ; }


Chroma兼容性：IE4.0+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Chroma ( enabled=bEnabled , color=sColor )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.Chroma ( sProperties ) "
说明：
将对象中指定的颜色显示为透明。
不建议在8位到24位抖动的图片文件上使用此滤镜。例如保存时会抖动和压缩的JPEG格式图片文件，应用此滤镜，其结果会很难看。
此效果在羽化(柔化色彩以同周围相邻的颜色平和的过渡)的线条等处也不会很好的作用。
确定的 color 参数值可能会导致图片自身的透明颜色变为不透明。
示例：
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.Chroma(color='yellow'), progid:DXImageTransform.Microsoft.Chroma(color='red') ; }
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.Chroma(color='yellow') ; }


Compositor兼容性：IE5.5+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Compositor ( function=sFunction )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.Compositor ( sProperties ) "
说明：
依据初始对象和新对象色彩的特定混合方式显示新的对象内容。
这个滤镜提供了丰富的将输入对象的色彩和透明度相互作用的图像合成的功能设置。要建立转换滤镜，遵循下列步骤：
  1. 选择一个功能( function )。
  2. 设置对象的合成滤镜( filter )的属性声明。
  3. 确定滤镜对象初始显示的内容。合成功能将此作为输入 A 。
  4. 使用合成滤镜的 apply 方法。捕获对象内容的初始显示，为转换做必要的准备。
  5. 改变对象的属性，如 visibility ， innerText ， background-color ， border ，或者其子对象的属性。合成功能将此作为输入 B 。
  6. 使用合成滤镜的 play 方法。这会将合成功能输出的图像变化显示出来。
示例：
#idDiv{ filter:progid:DXImageTransform.Microsoft.Compositor(function=20, duration=7);}


DropShadow兼容性：IE4.0+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.DropShadow ( enabled=bEnabled , color=sColor , offX=iOffsetX , offY=iOffsetY , positive=bPositive )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.DropShadow ( sProperties ) "
说明：
制作对象的阴影效果。
示例：
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.dropshadow(OffX=5, OffY=5, Color='gray', Positive=true); }
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.dropshadow(Positive=true) ; }


Emboss兼容性：IE5.5+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Emboss ( enabled=bEnabled , Bias=fBias )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.Emboss ( sProperties ) "
说明：
用灰度值为对象内容制作浮雕纹理效果。
示例：
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.emboss(enabled='false') ; }


Engrave兼容性：IE5.5+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Engrave ( enabled=bEnabled , Bias=fBias )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.Engrave ( sProperties ) "
说明：
用灰度值为对象内容制作浮雕纹理效果。
示例：
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.emboss(enabled='false') ; }


Glow兼容性：IE4.0+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Glow ( enabled=bEnabled , color=sColor , strength=iDistance )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.Glow ( sProperties ) "
说明：
环绕对象内容边缘添加辉光制作发热效果。辉光将出现在对象边界内的内容的最外轮廓之外。
  • 假如对象内有文本而无背景( background )和图片，则每个文本字符将会被辉光环绕。
  • 假如对象内有背景( background )或图片，则整个对象容器会被辉光环绕。
  • 假如对象的子对象定位超出了对象边界，则仅仅在对象容器内的内容会被辉光环绕。
示例：
#idDiv{position:absolute; left:140px; height:400; width:400;filter: glow(Color=blue,Strength=5) ; }
#idDiv{position:absolute; left:140px; height:400; width:400;filter: glow(color=#000000) ; }


Light兼容性：IE4.0+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Light ( enabled=bEnabled )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.Light ( sProperties ) "
说明：
为对象的内容建立光照效果。
你可以控制光源的虚拟位置，还可以控制光焦点的横纵坐标值。以及光的类型和强度。每个滤镜最多可以添加 10 束光。要想在页面上添加更多的光，你必须使用多个滤镜。
当每束光被建立后，都有默认的环境光与之关联。你添加到对象的第一束光会替换掉它的默认的环境光。
示例：
.aFilter { background-color: #FFFFFF; filter:light();color: cyan;width: 150;}


MaskFilter兼容性：IE4.0+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.MaskFilter ( enabled=bEnabled , color=sColor )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.MaskFilter ( sProperties ) "
说明：
将对象内容的透明像素用 color 参数指定的颜色显示作为一个遮罩，而非透明像素则转为透明。
使用 BasicImage 滤镜能够更有效率的实现这一效果。
示例：
DIV.aFilter {filter:mask(color=#008800); width: 100;}


Matrix兼容性：IE5.5+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Matrix ( enabled=bEnabled , SizingMethod=sMethod , FilterType=sType , Dx=fDx , Dy=fDy , M11=fM11 , M12=fM12 , M21=fM21 , M22=fM22 )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.Matrix ( sProperties ) "
说明：
使用矩阵变形实现对象内容的改变尺寸、旋转、上下或左右反转。
使用此滤镜可以建立下列效果：
  1. 左右反转。将 M11 和 M12 的值取负。
  2. 上下反转。将 M21 和 M22 的值取负。
  3. 改变尺寸。将 M11 和 M12 和 M21 和 M22 的值乘以相同的因数。对象内容尺寸会按比例增大或缩小。
使用 padding 属性能够使最终图像边角被剪切的机会降到最小。
示例：
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.Matrix(enabled='false') ; }
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.Matrix(M11=1.0, sizingmethod="auto expand"); }


MotionBlur兼容性：IE4.0+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.MotionBlur ( enabled=bEnabled , add=bAddImage , direction=iOffset , strength=iDistance )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.MotionBlur ( sProperties ) "
说明：
为对象内容制作运动模糊效果。
示例：
DIV.aFilter {filter:progid:DXImageTransform.Microsoft.MotionBlur(Strength=5,Direction=90);}
#oDIV {filter:progid:DXImageTransform.Microsoft.MotionBlur(Strength=10, Direction=45, Add='true');}


Shadow兼容性：IE4.0+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Shadow ( enabled=bEnabled , color=sColor , direction=iOffset , strength=iDistance )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.Shadow ( sProperties ) "
说明：
为对象内容建立阴影效果。
示例：
DIV.aFilter {filter:progid:DXImageTransform.Microsoft.Shadow(Strength=5,Direction=90);}
#oDIV {filter:progid:DXImageTransform.Microsoft.Shadow(Strength=10, Direction=45, color=blue);}


Wave兼容性：IE4.0+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Wave ( enabled=bEnabled , add=bAddImage , freq=iWaveCount , lightStrength=iPercentage , phase=iPercentage , strength=iDistance )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.Wave ( sProperties ) "
说明：
为对象内容建立波纹扭曲效果。
示例：
DIV.aFilter {filter:progid:DXImageTransform.Microsoft.Wave(Strength=5);}
#oDIV {filter:progid:DXImageTransform.Microsoft.Wave(Strength=10, Add=true);}


ICMFilter兼容性：IE5.5+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.ICMFilter ( colorSpace=sPathFilename , intent =sIntent )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.ICMFilter ( sProperties ) "
说明：
根据颜色配置文件(.icm)转换对象的色彩内容。这样能激活对某些细节内容的显示改良，或对硬件设备输出的模拟显示。像打印机或显示器。
通过根据要显示内容的类型匹配恰当的 Intent 特性值可以改善内容显示或打印的质量。例如，当你打印时，可以设置 Intent 特性值为 Graphic 从而确保颜色对比度的恰当。较高的对比度能够使打印出的内容清晰易读。
要模拟硬件设备的色彩输出，你必须定位硬件设备的颜色配置文件(.icm)，假如制造商提供了这个文件。将这个颜色配置文件(.icm)的路径和名称指给 ColorSpace 特性，并且对硬件装置要使用的内容应用此滤镜。颜色配置文件(.icm)为你的显示器定义了内容的颜色与显示器标准颜色的偏差。这样滤镜显示就可以模拟 其他硬件设备的输出。
示例：
#idDiv{ filter:progid:DXImageTransform.Microsoft.ICMFilter(colorSpace=sRGB, intent=Picture);}


Gray兼容性：IE4.0+
语法：
CSS | filter : Gray ( enabled=bEnabled )
Scripting | object.style.filter = "Gray ( sProperties ) "
说明：
灰度显示对象内容。
使用 BasicImage 滤镜可以更有效率的建立效果。
示例：
#idDiv{ height:250px; width:250px; filter:Gray(); }


Invert兼容性：IE4.0+
语法：
CSS | filter : Invert ( enabled=bEnabled )
Scripting | object.style.filter = "Invert ( sProperties ) "
说明：
反相显示对象内容。
使用 BasicImage 滤镜可以更有效率的建立效果。
示例：
#idDiv{ height:250px; width:250px; filter:Invert(); }


Xray兼容性：IE4.0+
语法：
CSS | filter : Xray ( enabled=bEnabled )
Scripting | object.style.filter = "Xray ( sProperties ) "
说明：
以X光效果显示对象内容。
使用 BasicImage 滤镜可以更有效率的建立效果。
示例：
#idDiv{ height:250px; width:250px; filter:Xray(); }


FlipH兼容性：IE4.0+
语法：
CSS | filter : FlipH ( enabled=bEnabled )
Scripting | object.style.filter = "FlipH ( sProperties ) "
说明：
水平翻转对象内容。
使用 BasicImage 滤镜可以更有效率的建立效果。
示例：
#idDiv{ height:250px; width:250px; filter:FlipH(); }


FlipV兼容性：IE4.0+
语法：
CSS | filter : FlipV ( enabled=bEnabled )
Scripting | object.style.filter = "FlipV ( sProperties ) "
说明：
垂直翻转对象内容。
使用 BasicImage 滤镜可以更有效率的建立效果。
示例：
#idDiv{ height:250px; width:250px; filter:FlipV(); }


Redirect兼容性：无
说明：
目前未被支持。


Barn兼容性：IE5.5+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Barn ( enabled=bEnabled , duration=fDuration , motion=sMotion , orientation=sOrientation )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.Barn ( sProperties ) "
说明：
用模拟开关门效果转换对象内容。
示例：
#idDiv{ filter:progid:DXImageTransform.Microsoft.Barn(function=20, duration=7);}


BlendTrans兼容性：IE4.0+
语法：
CSS | filter : BlendTrans ( enabled=bEnabled , duration=fDuration )
Scripting | object.style.filter = "BlendTrans ( sProperties ) "
说明：
用渐隐效果转换对象内容。
使用 BasicImage 滤镜可以更有效率的建立效果。
示例：
#idDiv{ height:250px; width:250px; background-color: gold; filter:BlendTrans(duration=5); }


Blinds兼容性：IE5.5+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Blinds ( enabled=bEnabled , duration=fDuration , bands=iBands , Direction=sDirection )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.Blinds ( sProperties ) "
说明：
用百叶窗开关效果转换对象内容。
示例：
#idDiv{ filter:progid:DXImageTransform.Microsoft.Blinds(direction='down');}


CheckerBoard兼容性：IE5.5+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.CheckerBoard ( enabled=bEnabled , duration=fDuration , squaresX=iColumns , squaresY=iColumns , Direction=sDirection )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.CheckerBoard ( sProperties ) "
说明：
用类似国际象棋棋盘的网格推拉效果转换对象内容。
示例：
#idDiv{ height:250px; width:250px; background-color: gold; filter:progid:DXImageTransform.Microsoft.CheckerBoard(duration=5, direction='left'); }


Fade兼容性：IE5.5+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Fade ( enabled=bEnabled , duration=fDuration , overlap=fOverlap )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.Fade ( sProperties ) "
说明：
用渐隐效果转换对象内容。
示例：
#idDiv{ height:250px; width:250px; background-color: gold; filter:progid:DXImageTransform.Microsoft.Fade(duration=2);}


GradientWipe兼容性：IE5.5+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.GradientWipe ( enabled=bEnabled , duration=fDuration , gradientSize=fGradientWidth , motion=sMotion )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.GradientWipe ( sProperties ) "
说明：
用滚动渐隐效果转换对象内容。
示例：
#idDiv{height:250px; width:250px; background-color: orange; filter:progid:DXImageTransform.Microsoft.gradientWipe(duration=3, gradientsize=0.5);}


Inset兼容性：IE5.5+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Inset ( enabled=bEnabled , duration=fDuration )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.Inset ( sProperties ) "
说明：
用对角扩张效果转换对象内容。
示例：
#idDiv{ height:250px; width:250px; background-color: gold; filter:progid:DXImageTransform.Microsoft.Inset();}


Iris兼容性：IE5.5+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Iris ( enabled=bEnabled , duration=fDuration , irisStyle=sShape , motion=sMotion )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.Iris ( sProperties ) "
说明：
用特殊形状剪切轮廓扩张或收缩显示效果转换对象内容。
示例：
#idDiv{ height:250px; width:250px; background-color: gold; filter:progid:DXImageTransform.Microsoft.Iris(duration=3);}


Pixelate兼容性：IE5.5+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Pixelate ( enabled=bEnabled , duration=fDuration , maxSquare=iWidth )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.Pixelate ( sProperties ) "
说明：
这个转换滤镜是一个复杂的视觉效果。在转换的前半段，对象内容先显示为矩形色块拼贴，然后矩形的宽度由一个像素增加至 MaxSquare 属性所设置的值。每个矩形的颜色由其所覆盖区域的像素的颜色平均值决定。接下来的转换的后半段，矩形被还原为新内容具体的图像像素，显示出新的内容。
在使用此转换滤镜前设置此滤镜的 Enabled 特性值为 false 。这将预防在转换发生前彩色拼贴效果的静态滤镜先在对象内容上发生作用。
示例：
#idDiv{ height:250px; width:250px; background-color: gold; filter:progid:DXImageTransform.Microsoft.Pixelate(duration=3, enabled='false');}


RadialWipe兼容性：IE5.5+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.RadialWipe ( enabled=bEnabled , duration=fDuration ,wipeStyle=sStyle )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.RadialWipe ( sProperties ) "
说明：
用放射状擦除效果转换对象内容。效果类似汽车挡风玻璃的刮雨刀。
示例：
#idDiv{height:250px; width:250px; background-color: orange; filter:progid:DXImageTransform.Microsoft.RadialWipe(duration=3);}


RandomBars兼容性：IE5.5+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.RandomBars ( enabled=bEnabled , duration=fDuration , orientation=sOrientation )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.RandomBars ( sProperties ) "
说明：
用随机发生的线条转换对象内容。
示例：
#idDiv{height:250px; width:250px; background-color: orange; filter:progid:DXImageTransform.Microsoft.RandomBars(duration=3);}


RandomDissolve兼容性：IE5.5+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.RandomDissolve ( enabled=bEnabled , duration=fDuration )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.RandomDissolve ( sProperties ) "
说明：
用随机像素溶解效果转换对象内容。
示例：
#idDiv{ height:250px; width:250px; background-color: gold; filter:progid:DXImageTransform.Microsoft.RandomDissolve();}


RevealTrans兼容性：IE5.5+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.RevealTrans ( enabled=bEnabled , duration=fDuration , transition=iTransitionType )
CSS | filter : RevealTrans ( enabled=bEnabled , duration=fDuration , transition=iTransitionType )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.RevealTrans ( sProperties ) "
Scripting | object.style.filter = "RevealTrans ( sProperties ) "
说明：
提供了24种转换对象内容的效果。
示例：
#idDiv{ height:250px; width:250px; background-color: gold; filter:progid:DXImageTransform.Microsoft.RevealTrans(duration=5, transition=2); }


Slide兼容性：IE5.5+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Slide ( enabled=bEnabled , duration=fDuration , bands=iBands , slideStyle=sslideStyle )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.Slide ( sProperties ) "
说明：
用滑条抽离效果转换对象内容。
示例：
#idDiv{ filter:progid:DXImageTransform.Microsoft.Slide(bands=8, duration=7);}


Spiral兼容性：IE5.5+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Spiral ( enabled=bEnabled , duration=fDuration , gridSizeX=iColumns , gridSizeY=iColumns )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.Spiral ( sProperties ) "
说明：
用矩形螺旋方式转换对象内容。
示例：
#idDiv{ height:250px; width:250px; background-color: gold; filter:progid:DXImageTransform.Microsoft.Spiral(duration=5, GridSizeX=25, GridSizeY=25); }


Stretch兼容性：IE5.5+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Stretch ( enabled=bEnabled , duration=fDuration , stretchStyle=sStretchStyle )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.Stretch ( sProperties ) "
说明：
用拉伸(缩)变形效果转换对象内容。
示例：
#idDiv{height:250px; width:250px; background-color: orange; filter:progid:DXImageTransform.Microsoft.Stretch(duration=3);}


Strips兼容性：IE5.5+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Strips ( enabled=bEnabled , duration=fDuration , motion=sMotion )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.Strips ( sProperties ) "
说明：
用锯齿边覆盖效果转换对象内容。
示例：
#idDiv{height:250px; width:250px; background-color: orange; filter:progid:DXImageTransform.Microsoft.Strips(duration=3);}


Wheel兼容性：IE5.5+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Wheel ( enabled=bEnabled , duration=fDuration , spokes=iSpokes )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.Wheel ( sProperties ) "
说明：
用风车叶轮旋转效果转换对象内容。
示例：
#idDiv{height:250px; width:250px; background-color: orange; filter:progid:DXImageTransform.Microsoft.Wheel(duration=3,spokes=8);}


Zigzag兼容性：IE5.5+
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Zigzag ( enabled=bEnabled , duration=fDuration , gridSizeX=iColumns , gridSizeY=iColumns )
Scripting | object.style.filter = "progid:DXImageTransform.Microsoft.Zigzag ( sProperties ) "
说明：
用类似擦地板的效果转换对象内容。
示例：
#idDiv{ height:250px; width:250px; background-color: gold; filter:progid:DXImageTransform.Microsoft.Zigzag(duration=5, GridSizeX=25, GridSizeY=25); }


addAmbient版本：DHTML Object Model　返回值：无
语法：
Scripting object.filters.item('DXImageTransform.Microsoft.Light').addAmbient ( iRed , iGreen , iBlue , iStrength )
参数：
iRed | : | 必选项。整数值(Integer)。 指定红色值。取值范围为 0 - 255 。
iGreen | : | 必选项。整数值(Integer)。 指定绿色值。取值范围为 0 - 255 。
iBlue | : | 必选项。整数值(Integer)。 指定蓝色值。取值范围为 0 - 255 。
iStrength | : | 必选项。整数值(Integer)。 指定光强度。取值范围为 0 - 100 。
返回值：
无
说明：
为 Light 滤镜添加环境光(Ambient Light )。环境光是无方向的，并且均匀的洒在页面的表面。环境光有颜色和强度值，可以为对象田家更多的颜色。它通常和其他光一起使用。


addCone版本：DHTML Object Model　返回值：无
语法：
Scripting object.filters.item('DXImageTransform.Microsoft.Light').addCone ( iX1 , iY1 , iZ1 , iX2 , iY , iRed , iGreen , iBlue , iStrength , iSpread )
参数：
iX1 | : | 必选项。整数值(Integer)。指定光源的左坐标值。
iY1 | : | 必选项。整数值(Integer)。指定光源的上坐标值。
iZ1 | : | 必选项。整数值(Integer)。指定光源的Z坐标值。
iX2 | : | 必选项。整数值(Integer)。指定光焦点的左坐标值。
iY2 | : | 必选项。整数值(Integer)。指定光焦点的上坐标值。
iRed | : | 必选项。整数值(Integer)。指定红色值。取值范围为 0 - 255 。
iGreen | : | 必选项。整数值(Integer)。指定绿色值。取值范围为 0 - 255 。
iBlue | : | 必选项。整数值(Integer)。指定蓝色值。取值范围为 0 - 255 。
iStrength | : | 必选项。整数值(Integer)。指定光强度。取值范围为 0 - 100 。
iSpread | : | 必选项。整数值(Integer)。指定光源的虚拟位置与对象的表面之间的角度或张度。取值范围为 0 - 90 。
返回值：
无
说明：
为 Light 滤镜添加锥形光(Cone Light)以向对象的表面投射有方向的光束。光束会随延伸的距离而逐渐减弱。


addPoint版本：DHTML Object Model　返回值：无
语法：
Scripting object.filters.item('DXImageTransform.Microsoft.Light').addPoint ( iX , iY , iZ , iRed , iGreen , iBlue , iStrength )
参数：
iX | : | 必选项。整数值(Integer)。指定光源的左坐标值。
iY | : | 必选项。整数值(Integer)。指定光源的上坐标值。
iZ | : | 必选项。整数值(Integer)。指定光源的Z坐标值。
iRed | : | 必选项。整数值(Integer)。指定红色值。取值范围为 0 - 255 。
iGreen | : | 必选项。整数值(Integer)。指定绿色值。取值范围为 0 - 255 。
iBlue | : | 必选项。整数值(Integer)。指定蓝色值。取值范围为 0 - 255 。
iStrength | : | 必选项。整数值(Integer)。指定光强度。取值范围为 0 - 100 。
返回值：
无
说明：
为 Light 滤镜添加点光(Point Light)。


apply版本：DHTML Object Model　返回值：无
语法：
Scripting object.filters.item('DXImageTransform.Microsoft. sFilterName ').apply ()
参数：
无
返回值：
无
说明：
捕获对象内容的初始显示，为转换做必要的准备。无返回值。
当此方法一旦被调用后，对象属性的任何改变都不会被显示，直到你调用 play 方法开始转换。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
当你调用 play 方法时，转换呈现出内容的变化结果(对象的属性和子对象的 visibility 属性的改变)。


changeColor版本：DHTML Object Model　返回值：无
语法：
Scripting object.filters.item('DXImageTransform.Microsoft.Light').changeColor ( iLightNumber , iRed , iGreen , iBlue , fAbsolute )
参数：
iLightNumber : 必选项。整数值(Integer)。指定光的标识符。此数值依据光被添加的顺序编号。如第一个被添加的光的标识符就等于 0 。
iRed : 必选项。整数值(Integer)。指定红色值。取值范围为 0 - 255 。
iGreen : 必选项。整数值(Integer)。指定绿色值。取值范围为 0 - 255 。
iBlue : 必选项。整数值(Integer)。指定蓝色值。取值范围为 0 - 255 。
fAbsolute : 必选项。布尔值(Boolean)。指定改变是替换当前设置的绝对值，还是加到当前设置的相对值。此参数不等于零表示采用绝对值。否则表示采用相对值。
false | : | 指定改变是增加到当前设置的相对值。
true | : | 指定改变是替换当前设置的绝对值。
返回值：
无
说明：
改变 Light 滤镜的光的颜色。


changeStrength版本：DHTML Object Model　返回值：无
语法：
Scripting object.filters.item('DXImageTransform.Microsoft.Light').changeStrength ( iLightNumber , iStrength , fAbsolute )
参数：
iLightNumber : 必选项。整数值(Integer)。 指定光的标识符。此数值依据光被添加的顺序编号。如第一个被添加的光的标识符就等于 0 。
iStrength : 必选项。整数值(Integer)。指定光强度。取值范围为 0 - 100 。
fAbsolute : 必选项。布尔值(Boolean)。指定改变是替换当前设置的绝对值，还是加到当前设置的相对值。此参数不等于 0 表示采用绝对值。否则表示采用相对值。
false | : | 指定改变是增加到当前设置的相对值。
true | : | 指定改变是替换当前设置的绝对值。
返回值：
无
说明：
改变 Light 滤镜的光的强度。


clear版本：DHTML Object Model　返回值：无
语法：
Scripting object.filters.item('DXImageTransform.Microsoft.Light').clear ()
参数：
无
返回值：
无
说明：
清除所有与当前 Light 滤镜关联的光。


elementImage版本：DHTML Object Model　返回值：无
说明：
返回 DAImage(Direct Animation Image) 对象。目前未被支持。


item版本：DHTML Object Model　返回值：有
语法：
Scripting oItem = object . item ( vIndex )
参数：
vIndex : 必选项。整数值(Integer) | 字符串(String)
如果此参数使用的是整数值，则返回数组中的整数序号等于此参数值的对象。如此参数值等于 0 则返回数组中的第一个对象。
如果此参数值使用的是字符串值，则返回数组中所有 name 或 id 属性等于此参数值的对象。假如符合条件的对象数目多于一个，则返回的将是一个数组。
返回值：
oItem : 必选项。对象(Object)。假如成功返回获取到的对象或数组。否则返回 null 。
说明：
从 filters 集合或其他集合中返回符合条件的对象。
示例：
oDiv.filters.item('DXImageTransform.Microsoft.Light').clear();
oDiv.filters['DXImageTransform.Microsoft.Light'].clear();
oDiv.filters.item(0).clear();
oDiv.filters.item[0].moveLight(0,180,60,20,false);


moveLight版本：DHTML Object Model　返回值：无
语法：
Scripting object.filters.item('DXImageTransform.Microsoft.Light').moveLight ( iLightNumber , iX , iY , iZ , fAbsolute )
参数：
iLightNumber : 必选项。整数值(Integer)。指定光的标识符。此数值依据光被添加的顺序编号。如第一个被添加的光的标识符就等于 0 。
iX : 必选项。整数值(Integer)。指定光源的左坐标值。
iY : 必选项。整数值(Integer)。指定光源的上坐标值。
iZ : 必选项。整数值(Integer)。指定光源的Z坐标值。
fAbsolute : 必选项。布尔值(Boolean)。指定改变是替换当前设置的绝对值，还是加到当前设置的相对值。此参数不等于 0 表示采用绝对值。否则表示采用相对值。
false | : | 指定改变是增加到当前设置的相对值。
true | : | 指定改变是替换当前设置的绝对值。
返回值：
无
说明：
移动锥形光(Cone Light)的焦点或点光(Point Light)的原点。对于锥形光来说，此方法改变 x,y 目标坐标值；对于点光来说，此方法改变 x,y,z 源坐标值。 此方法不作用于环境光。


namedItem版本：DOM1　返回值：有
语法：
Scripting oItem = object . namedItem ( sName )
参数：
sName : 必选项。字符串(String)。
返回值：
oItem : 对象(Object)或数组(Array)。如果不成功返回 null 。
说明：
返回集合中 name 属性值或 id 属性值等于 sName 的对象或一组对象的集合。
此方法先在集合中搜寻 id 属性值等于 sName 的对象，如果没有找到，再搜寻 name 属性值等于 sName 的对象。但只获取本身拥有 name 属性和 id 属性的对象。使用自定义( expando )的 name 属性的对象不会被获取。


play版本：DHTML Object Model　返回值：无
语法：
Scripting object.filters.item('DXImageTransform.Microsoft. sFilterName ').play( iDuration )
参数：
iDuration : 可选项。浮点数(Real)。 指定滤镜作用持续的时间。默认单位为秒(s)。
返回值：
无
说明：
开始转换。
使用 play 方法的 iDuration 参数设置转换回放的持续时间，其值在转换的当前一个周期内会替换 Duration 属性的设置。但是下一次转换会恢复使用 Duration 属性设置的值。


stop版本：DHTML Object Model　返回值：无
语法：
Scripting object.filters.item('DXImageTransform.Microsoft. sFilterName ').stop ()
参数：
无
返回值：
无
说明：
停止转换回放。并呈现转换结果图像。同时激发 onfilterchange 事件。


add | Add版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft. sFilterName ( add = bAddImage )
Scripting | object.filters.item('DXImageTransform.Microsoft. sFilterName ').Add = bAddImage
取值：
bAddImage : 布尔值(Boolean)。true | false
true | : | 滤镜作用图像覆盖原始图像。
false | : | 默认值。只显示滤镜作用图像。
说明：
设置或检索滤镜作用图像是否覆盖原始图像。


bands | bands版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft. sFilterName ( bands = iBands )
Scripting | object.filters.item('DXImageTransform.Microsoft. sFilterName ').bands = iBands
取值：
iBands : 整数值(Integer)。取值范围为 1 - 100 。 此属性无默认值。以下为例外:
Blinds | : | 10
Slide | : | 1
说明：
此属性作用于下列滤镜有不同的作用:
Blinds | : | 设置或检索滤镜效果中有多少条百叶窗的窗格出现。
Slide | : | 设置或检索滤镜效果中有多少滑条被抽离。


Bias | Bias版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft. sFilterName ( Bias = fBias )
Scripting | object.filters.item('DXImageTransform.Microsoft. sFilterName ').Bias = fBias
取值：
fBias : 浮点数(Float)。取值范围为 -1.0 - 1.0 。默认值为 0.7 。
说明：
设置或检索添加到滤镜结果的每种颜色组分的值的百分比。大的此属性值产生高亮滤光效果。高对比度的图片受滤镜的影响较小。


cancelBubble版本：DHTML Object Model　读/写
语法：
Scripting event . cancelBubble = bCancel
取值：
bCancel : 布尔值(Boolean)。false | true
false | : | 默认值。激活事件冒泡。允许在事件处理层次结构中的下一个事件处理者接收到事件。
true | : | 禁止事件冒泡。阻止在层次结构中的下一个事件处理者接收到事件。
说明：
设置或检索当前事件是否允许在事件处理层次结构中向上冒泡。
使用此属性取消一个事件的冒泡不会影响其后继事件。


colorSpace | ColorSpace版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.ICMFilter ( colorSpace = sPathFilename )
Scripting | object.filters.item('DXImageTransform.Microsoft.ICMFilter').ColorSpace = sPathFilename
取值：
sPathFilename : 字符串(String)。 sFile | sRGB
sFile | : | 默认值。确定颜色配置文件(.icm)的路径和名称。
sRGB | : | 确定标准颜色空间。
说明：
设置或检索颜色配置文件(.icm)的路径和名称。如果颜色配置文件(.icm)被指定，滤镜输出将模拟使用此颜色配置文件(.icm)的硬件设备的输出。
颜色配置文件(.icm)为硬件装置定义了色彩内容与 sRGB 标准的映射比较。
示例：
#idDiv{ filter:progid:DXImageTransform.Microsoft.ICMFilter(colorSpace=sRGB, intent=Picture);}


Color | Color版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Shadow ( Color = sColor )
Scripting | object.filters.item('DXImageTransform.Microsoft.Shadow').Color = sColor
取值：
sColor : 字符串(String)。其格式为 #RRGGBB 。 RR 、 GG 、 BB 为十六进制正整数。取值范围为 00 - FF 。 RR 指定红色值， GG 指定绿色值， BB 指定蓝色值。
说明：
设置或检索 Shadow 滤镜作用的颜色值。


color | Color版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft. sFilterName ( color = sColor )
Scripting | object.filters.item('DXImageTransform.Microsoft. sFilterName ').Color = sColor
取值：
sColor : 字符串(String)。32位 ARGB 格式色彩值。
其格式为 #AARRGGBB 。 AA 、 RR 、 GG 、 BB 为十六进制正整数。取值范围为 00 - FF 。 RR 指定红色值， GG 指定绿色值， BB 指定蓝色值， AA 指定透明度。 00 是完全透明。 FF 是完全不透明。
此属性无默认值。以下为例外:
Chroma | : | #FF0000FF
DropShadow | : | #FF404040
Glow | : | #FF0000
MaskFilter | : | #FF000000
说明：
设置或检索滤镜作用的颜色值。
对于 Glow 滤镜而言，此属性的取值被限制为 #RRGGBB 格式。因为辉光发热效果总是不透明的。
此属性作用于下列滤镜有不同的作用:
Chroma | : | 指定被透视的颜色。
DropShadow | : | 指定阴影效果的颜色。
Glow | : | 指定辉光发热效果的颜色。
MaskFilter | :  | 指定显示为透明的颜色。


direction | Direction版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft. sFilterName ( direction = iOffset )
Scripting | object.filters.item('DXImageTransform.Microsoft. sFilterName ').Direction = iOffset
取值：
iOffset : 整数值(Integer)。默认单位为角度。0 | 45 | 90 | 135 | 180 | 225 | 270 | 315
0 | : | 上。
45 | : | 右上。
90 | : | 下。
135 | : | 右下。
180 | : | 下。
225 | : | 默认值。左下。
270 | : | 左。
315 | : | 左上。
说明：
设置或检索滤镜效果的运动偏移方向。小于 0 或大于 360 的值会自动转换为 0 - 360 之间的值。例如， -45 会转换为 315 。


Direction | Direction版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft. sFilterName ( Direction = sDirection )
Scripting | object.filters.item('DXImageTransform.Microsoft. sFilterName ').Direction = sDirection
取值：
sDirection : 字符串(String)。down | up | right | left
down | : | 向下。
up | : | 向上。
right | : | 向右。
left | : | 向左。

此属性无默认值。以下为例外:
CheckerBoard | : | down
Blinds | : | right
说明：
设置或检索转换效果的方向。此属性作用于下列滤镜有不同的作用:
CheckerBoard | : | 设置或检索网格推拉的方向。
Blinds | : | 设置或检索百叶窗开关的方向。


duration | Duration 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft. sFilterName ( duration = fDuration )
Scripting | object.filters.item('DXImageTransform.Microsoft. sFilterName ').Duration = fDuration
取值：
fDuration : 浮点数(Real)。其值为秒.毫秒(0.0000)格式。
说明：
设置或检索转换完成所用的时间。你可以使用 play 方法的 iDuration 参数设置转换回放的持续时间。然而，当你一旦调用了 play 方法，在回放持续过程中 Duration 特性就变为只读特性。


Dx | Dx 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Matrix ( Dx = fDx )
Scripting | object.filters.item('DXImageTransform.Microsoft.Matrix').Dx = fDx
取值：
fDx : 浮点数(Float)。默认值为 1.0 。
说明：
设置或检索线性转换的向量增加 X 。当 SizingMethod 属性设置为 auto expand 时此属性设置被忽略。


Dy | Dy 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DyImageTransform.Microsoft.Matrix ( Dy = fDy )
Scripting | object.filters.item('DyImageTransform.Microsoft.Matrix').Dy = fDy
取值：
fDy : 浮点数(Float)。默认值为 1.0 。
说明：
设置或检索线性转换的向量增加 Y 。当 SizingMethod 属性设置为 auto expand 时此属性设置被忽略。


enabled | Enabled 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft. sFilterName ( enabled = bEnabled )
Scripting | object.filters.item('DXImageTransform.Microsoft. sFilterName ').Enabled = bEnabled
取值：
bEnabled : 布尔值(Boolean)。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
说明：
设置或检索滤镜是否激活。改变此属性值会激发 onfilterchange 事件。


EndColor 版本：DHTML Object Model　读/写
语法：
Scripting object.filters.item('DXImageTransform.Microsoft.Gradient').EndColor = sColor
取值：
sColor : 整数值(Integer)。 无默认值。取值范围为 0 - 4294967295 。 0 为透明。 4294967295 为不透明白色。当在脚本中使用此特性时，也可以用十六进制格式： 0xAARRGGBB 。
说明：
设置或检索色彩渐变的结束颜色。


EndColorStr 版本：DHTML Object Model　读/写
语法：
Scripting object.filters.item('DXImageTransform.Microsoft.Gradient').EndColorStr = iWidth
取值：
iWidth : 字符串(String)。32位 ARGB 格式色彩值。
其格式为 #AARRGGBB 。 AA 、 RR 、 GG 、 BB 为十六进制正整数。取值范围为 00 - FF 。 RR 指定红色值， GG 指定绿色值， BB 指定蓝色值。 AA 指定透明度。 00 是完全透明。 FF 是完全不透明。超出取值范围的值将被恢复为默认值。
取值范围为 #FF000000 - #FFFFFFFF 。默认值为 #FF000000 。不透明黑色。
说明：
设置或检索色彩渐变的结束颜色和透明度。


filter | filter 版本：DHTML Object Model　读/写
语法：
CSS | filter : sFilter
Scripting | object.style.filter = sFilter
取值：
sFilter : 要使用的滤镜效果。多个滤镜之间用空格隔开。请参阅样式表滤镜(Visual Filters and Transitions Reference)。
说明：
设置或检索对象所应用的滤镜或滤镜集合。
此属性仅作用于有布局的对象，如块对象。内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。请参阅对象的 hasLayout 属性。
若要在 img 对象上应用 shadow 滤镜，可以在该对象 img 对象的父容器上应用。
滤镜的机制是可扩展的。通过利用Microsoft® DirectX® Media SDK，你可以使用C++开发和使用第三方滤镜。
该属性在MAC平台上不可用。
示例：
div { width:200px; filter:blur(strength=50) flipv() ; }
img { filter: invert(); }
input.aFilter {filter: alpha(opacity=50);}
div { width:200px; filter:redirect ; }
.aFilter {background-color: #FFFFFF; filter: light(); color: #000000; width: 150;}
div.aFilter {filter: glow(Color=blue,Strength=5); width: 150;}
div.aFilter {filter: shadow(color=#0000FF,direction=45); width: 150; color: FF0000;}


FilterType | FilterType 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:FilterTypeImageTransform.Microsoft.Matrix ( FilterType = sType )
Scripting | object.filters.item('FilterTypeImageTransform.Microsoft.Matrix').FilterType = sType
取值：
sType : 字符串(String)。bilinear | nearest neighbor
bilinear | : | 默认值。使用双线性( bilinear )算法定义目标像素的色彩内容。
nearest neighbor | : | 使用领近相似( nearest neighbor )算法定义目标像素的色彩内容。
说明：
设置或检索定义新内容的像素的方法。
要想获得最好的平滑的静态滤镜效果，请使用 bilinear 方法参数。而当用于动画图像时， nearest neighbor 方法参数因其运算速度较快从而能够提供动画每秒更多图像。


finishOpacity | FinishOpacity 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Alpha ( finishOpacity = iOpacity )
Scripting | object.filters.item('DXImageTransform.Microsoft.Alpha').FinishOpacity = iOpacity
取值：
iOpacity : 整数值(Integer)。取值范围为 0 - 100 。默认值为 0 ，即完全透明。 100 为完全不透明。
说明：
设置或检索透明渐变的结束透明度。


finishX | FinishX 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Alpha ( finishX = iPercent )
Scripting | object.filters.item('DXImageTransform.Microsoft.Alpha').FinishX = iPercent
取值：
iPercent : 整数值(Integer)。其数值作为对象宽度的百分比值处理。默认值为 0 。
说明：
设置或检索 Alpha 滤镜透明渐变结束点的水平坐标。仅当 style 属性值设置为 1 ，即渐变样式为线性(linear)渐变时，此属性才会发生作用。


finishY | FinishY 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Alpha ( startY = iPercent )
Scripting | object.filters.item('DXImageTransform.Microsoft.Alpha').StartY = iPercent
取值：
iPercent : 整数值(Integer)。其数值作为对象高度的百分比值处理。默认值为 0 。
说明：
设置或检索 Alpha 滤镜透明渐变结束点的垂直坐标。仅当 style 属性值设置为 1 ，即渐变样式为线性(linear)渐变时，此属性才会发生作用。


freq | Freq 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Wave ( freq = iWaveCount )
Scripting | object.filters.item('DXImageTransform.Microsoft.Wave').Freq = iWaveCount
取值：
iWaveCount : 整数值(Integer)。默认值为 3 。
说明：
设置或检索滤镜建立的波浪数目。


function | Function 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Compositor ( function = sFunction )
Scripting | object.filters.item('DXImageTransform.Microsoft.Compositor').Function = sFunction
取值：
sFunction : 整数值(Integer)。 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 19 | 20 | 21 | 22 | 23 | 24 | 25
0 | : | 默认值。清除。不执行任何操作。
1 | : | MIN 。比较A和B的每一个像素的亮度，将亮度较低的像素点显示出来。
2 | : | MAX 。比较A和B的每一个像素的亮度，将亮度较高的像素点显示出来。
3 | : | A。仅仅显示A。
4 | : | A OVER B。在B之上显示A。A被完全显示，B通过A的透明区域显示出来。
5 | : | A IN B。显示被A被B包含的部分。只有两个图像 alpha 值都不为 0 的区域被显示。B不会有任何部分穿透显示。
6 | : | A OUT B。显示A没有被B包含的部分。B不会有任何部分穿透显示。
7 | : | A ATOP B。 显示A遮盖B，每个取样都通过B的 alpha 通道依比例测定获得。
8 | : | A SUBTRACT B。以B的颜色取样值减去A的相应颜色取样值的方式显示A。结果颜色通过A的 alpha 通道依比例测定获得。
9 | : | A ADD B。以B的颜色取样值加上A的相应颜色取样值的方式显示A。 结果颜色通过A的 alpha 通道依比例测定获得。
10 | : | A XOR B。显示A和B没有相互交叠的像素点。交叠的像素通过它们反转的 alpha 值依比例测定。
19 | : | B。仅仅显示B。
20 | : | B OVER A。在A之上显示B。B被完全显示，A通过B的透明区域显示出来。
21 | : | B IN A。显示被B被A包含的部分。只有两个图像 alpha 值都不为 0 的区域被显示。A不会有任何部分穿透显示。
22 | : | B OUT A。显示B没有被A包含的部分。A不会有任何部分穿透显示。
23 | : | B ATOP A。 显示B遮盖A，每个取样都通过A的 alpha 通道依比例测定获得。
24 | : | B SUBTRACT A。以A的颜色取样值减去B的相应颜色取样值的方式显示B。结果颜色通过B的 alpha 通道依比例测定获得。
25 | : | B ADD A。以A的颜色取样值加上B的相应颜色取样值的方式显示B。 结果颜色通过B的 alpha 通道依比例测定获得。
说明：
设置或检索混合方式。


gradientSize | GradientSize 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.GradientWipe ( gradientSize = fGradientWidth )
Scripting | object.filters.item('DXImageTransform.Microsoft.GradientWipe').GradientSize = fGradientWidth
取值：
fGradientWidth : 浮点数(Real)。取值范围为 0.0 - 1.0 。默认值为 0.25 。
0.0 | : | 渐隐条无宽度。
0.25 | : | 默认值。渐隐条宽度为对象内容宽度的 25% 。
1.0 | : | 渐隐条完全覆盖对象内容。
说明：
设置或检索对象内容被梯度渐隐条覆盖的百分比。


GradientType 版本：DHTML Object Model　读/写
语法：
Scripting object.filters.item('DXImageTransform.Microsoft.Gradient').GradientType = iOrientation
取值：
iOrientation : 整数值(Integer)。1 | 0
1 | : | 默认值。水平渐变。
0 | : | 垂直渐变。
说明：
设置或检索色彩渐变的方向。


grayScale | GrayScale版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.BasicImage ( grayScale = bGray )
Scripting | object.filters.item('DXImageTransform.Microsoft.BasicImage').GrayScale = bGray
取值：
bGray : 布尔值(Boolean)。0 | 1
1 | : | 以灰度效果显示对象内容。
0 | : | 默认值。显示对象的原始色彩。
说明：
设置或检索是否以灰度显示对象内容。


gridSizeX | GridSizeX 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft. sFilterName ( gridSizeX = iColumns )
Scripting | object.filters.item('DXImageTransform.Microsoft. sFilterName ').GridSizeX = iColumns
取值：
iColumns : 整数值(Integer)。取值范围为 1 - 100 。默认值为 16 。
说明：
设置或检索滤镜效果中横向盘旋多少次。


gridSizeY | GridSizeY 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DYImageTransform.Microsoft. sFilterName ( gridSizeY = iColumns )
Scripting | object.filters.item('DYImageTransform.Microsoft. sFilterName ').GridSizeY = iColumns
取值：
iColumns : 整数值(Integer)。取值范围为 1 - 100 。默认值为 16 。
说明：
设置或检索滤镜效果中纵向盘旋多少次。


intent | Intent版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.ICMFilter ( intent = sIntent )
Scripting | object.filters.item('DXImageTransform.Microsoft.ICMFilter').Intent = sIntent
取值：
sIntent : 字符串(String)。 Picture | Graphic | Proof | Match
Picture | : | 默认值。强调色彩连续性。适用于图像和照片。
Graphic | : | 强调颜色的饱和度胜过其色调和明度。适用于商业图片。
Proof | : | 使用最接近的颜色匹配不被支持的颜色。白点不被保护。
Match | : | 使用最接近的颜色匹配不被支持的颜色。白点受到保护。
说明：
设置或检索对象的色彩内容的预定效果。滤镜会根据选择的效果调整色彩输出改善内容显示。
要获取你的显示器或打印机的色彩处理能力的最大优势，选择最符合你的内容的此属性值。
示例：
#idDiv{ filter:progid:DXImageTransform.Microsoft.ICMFilter(intent=sRGB, intent=Picture);}


Invert版本：DHTML Object Model　读/写
语法：
Scripting object.filters.item('DXImageTransform.Microsoft.BasicImage').Invert = bInvert
取值：
bInvert : 布尔值(Boolean)。0 | 1
1 | : | 反相显示对象内容。
0 | : | 默认值。显示对象的原始色彩。
说明：
设置或检索对象内容是否反相显示。


irisStyle | IrisStyle 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Iris ( irisStyle = sShape )
Scripting | object.filters.item('DXImageTransform.Microsoft.Iris').IrisStyle = sShape
取值：
sShape : 字符串(String)。PLUS | DIAMOND | CIRCLE | CROSS | SQUARE | STAR
PLUS | : | 默认值。十字形。
DIAMOND | : | 菱形。
CIRCLE | : | 圆形。
CROSS | : | 交叉对角线形。
SQUARE | : | 矩形。
STAR | : | 星形。
说明：
设置或检索 Iris 滤镜的剪切轮廓的外形。


length版本：DOM1　读/写
语法：
Scripting object . length = iLength
取值：
iLength : 整数值(Integer)。无默认值。
说明：
设置或检索集合内的对象数目。
此属性是可读写的。对于下列对象来说，是只读的：

window.length 将返回 window 内包含的所有框架(frame)数目。
comment.length 将返回对象内的字符数目。
form.length 返回的计数不包括 input type=image 元素的数目。要访问 form 内的所有对象，使用 children 集合。
虽然此属性值对于大多数对象而言是只读的，但是对于下述对象是可读写的：


lightStrength | LightStrength 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Wave ( lightStrength = iPercentage )
Scripting | object.filters.item('DXImageTransform.Microsoft.Wave').LightStrength = iPercentage
取值：
iPercentage : 整数值(Integer)。取值范围为 0 - 100 。默认值为 100 。
说明：
设置或检索滤镜建立的波浪浪尖和波谷之间的距离。


M11 | M11 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:M11ImageTransform.Microsoft.Matrix ( M11 = fM11 )
Scripting | object.filters.item('M11ImageTransform.Microsoft.Matrix').M11 = fM11
取值：
fM11 : 浮点数(Float)。默认值为 1.0 。
说明：
设置或检索线性转换的第一行/第一列矩阵输入。


M12 | M12 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:M12ImageTransform.Microsoft.Matrix ( M12 = fM12 )
Scripting | object.filters.item('M12ImageTransform.Microsoft.Matrix').M12 = fM12
取值：
fM12 : 浮点数(Float)。默认值为 0.0 。
说明：
设置或检索线性转换的第一行/第二列矩阵输入。


M21 | M21 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:M21ImageTransform.Microsoft.Matrix ( M21 = fM21 )
Scripting | object.filters.item('M21ImageTransform.Microsoft.Matrix').M21 = fM21
取值：
fM21 : 浮点数(Float)。默认值为 0.0 。
说明：
设置或检索线性转换的第二行/第一列矩阵输入。


M22 | M22 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:M22ImageTransform.Microsoft.Matrix ( M22 = fM22 )
Scripting | object.filters.item('M22ImageTransform.Microsoft.Matrix').M22 = fM22
取值：
fM22 : 浮点数(Float)。默认值为 1.0 。
说明：
设置或检索线性转换的第二行/第二列矩阵输入。


makeShadow | MakeShadow 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Blur ( makeShadow = bShadow )
Scripting | object.filters.item('DXImageTransform.Microsoft.Blur').MakeShadow = bShadow
取值：
bShadow : 布尔值(Boolean)。 true | false
true | : | 对象的内容被处理为阴影。此时，整个对象被设置为黑色，然后被添加模糊效果。调整 ShadowOpacity 参数值可以控制其暗度。
false | : | 默认值。显示对象的原始色彩。
说明：
设置或检索对象的内容是否被处理为阴影显示。


mask | Mask版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.BasicImage ( mask = bMask )
Scripting | object.filters.item('DXImageTransform.Microsoft.BasicImage').Mask = bMask
取值：
bMask : 布尔值(Boolean)。0 | 1
1 | : | 添加遮罩。
0 | : | 默认值。显示对象的原始色彩。
说明：
设置或检索是否依据 MaskColor 的值为对象添加遮罩(Mask)。
示例：
oDiv.filters['DXImageTransform.Microsoft.BasicImage'].Mask=1;
oDiv.filters['DXImageTransform.Microsoft.BasicImage'].MaskColor=0xFF9900;


MaskColor版本：DHTML Object Model　读/写
语法：
Scripting object.filters.item('DXImageTransform.Microsoft.BasicImage').MaskColor = iColor
取值：
iColor : 整数值(Integer)。32位 ARGB 格式色彩值。
其格式为 0xAARRGGBB 。 AA 、 RR 、 GG 、 BB 为十六进制正整数。取值范围为 00 - FF 。 RR 指定红色值， GG 指定绿色值， BB 指定蓝色值。 AA 指定透明度。 00 是完全透明。 FF 是完全不透明。
取值范围为 0x00000000 - 0xFFFFFFFF 。默认值为 0x00000000 。不透明黑色。
说明：
设置或检索遮罩( Mask )颜色。
示例：
oDiv.filters['DXImageTransform.Microsoft.BasicImage'].Mask=1;
oDiv.filters['DXImageTransform.Microsoft.BasicImage'].MaskColor=0xFF9900;


maxSquare | MaxSquare 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Pixelate ( maxSquare = iWidth )
Scripting | object.filters.item('DXImageTransform.Microsoft.Pixelate').MaxSquare = iWidth
取值：
iWidth : 整数值(Integer)。取值范围为 2 - 50 。默认值为 50 。
说明：
设置或检索转换中矩形色块的最大宽度。


mirror | Mirror版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.BasicImage ( mirror = bMirror )
Scripting | object.filters.item('DXImageTransform.Microsoft.BasicImage').Mirror = bMirror
取值：
bMirror : 布尔值(Boolean)。0 | 1
1 | : | 反转显示对象内容。
0 | : | 默认值。正常显示对象内容。
说明：
设置或检索是否反转显示对象内容。


motion | Motion 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.GradientWipe ( motion = sMotion )
Scripting | object.filters.item('DXImageTransform.Microsoft.GradientWipe').Motion = sMotion
取值：
sMotion : 字符串(String)。forward | reverse
forward | : | 默认值。对象内容依据 WipeStyle 特性设定的流向出现。
reverse | : | 对象内容依据 WipeStyle 特性设定的流向的反方向出现。
说明：
设置或检索对象内容出现的方向是依据 WipeStyle 特性的设定，还是取反。


motion | Motion 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft. sFilterName ( motion = sMotion )
Scripting | object.filters.item('DXImageTransform.Microsoft. sFilterName ').Motion = sMotion
取值：
sMotion : 字符串(String)。out | in
out | : | 默认值。转换从对象的中心向四边进行。
in | : | 转换从对象的四边向中心进行。
说明：
设置或检索对象的新内容是先从外显示还是先从内显示。


motion | Motion 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Strips ( motion = sMotion )
Scripting | object.filters.item('DXImageTransform.Microsoft.Strips').Motion = sMotion
取值：
sMotion : 字符串(String)。leftdown | leftup | rightdown | Prightup
leftdown | : | 默认值。从左下角到右上角。
leftup | : | 从左上角到右下角。
rightdown | : | 从右下角到左上角。
rightup | : | 从右上角到左下角。
说明：
设置或检索转换新内容从哪一个角开始。


offX | OffX 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.DropShadow ( offX = iOffsetX )
Scripting | object.filters.item('DXImageTransform.Microsoft.DropShadow').OffX = iOffsetX
取值：
iOffsetX : 整数值(Integer)。单位为像素( px )。默认值为 5 。
说明：
设置或检索阴影在横坐标轴上以对象为基准的偏移量。正值向右偏移，负值向左偏移。


offY | OffY 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.DropShadow ( offY = iOffsetY )
Scripting | object.filters.item('DXImageTransform.Microsoft.DropShadow').OffY = iOffsetY
取值：
iOffsetY : 整数值(Integer)。单位为像素( px )。设默认值为 5 。
说明：
设置或检索阴影在纵坐标轴上以对象为基准的偏移量。正值向下偏移，负值向上偏移。


opacity | Opacity版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.BasicImage ( opacity = fOpacity )
Scripting | object.filters.item('DXImageTransform.Microsoft.BasicImage').Opacity = fOpacity
取值：
fOpacity : 浮点数(Float)。取值范围为 0.0 - 1.0 。默认值为 1.0 。不透明。 0.0 为完全透明。
说明：
设置对象内容的透明度。


opacity | Opacity版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Alpha ( opacity = iOpacity )
Scripting | object.filters.item('DXImageTransform.Microsoft.Alpha').Opacity = iOpacity
取值：
iOpacity : 整数值(Integer)。取值范围为 0 - 100 。默认值为 0 ，即完全透明。 100 为完全不透明。
说明：
设置或检索透明渐变的开始透明度。


orientation | Orientation 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft. sFilterName ( orientation = sOrientation )
Scripting | object.filters.item('DXImageTransform.Microsoft. sFilterName ').Orientation = sOrientation
取值：
sOrientation : 字符串(String)。vertical | horizontal
此属性无默认值。以下为例外:
RandomBars | : | horizontal
Barn | : | vertical
说明：
此属性作用于下列滤镜有不同的作用:
RandomBars | : | 设置或检索滤镜效果模拟的开关门是横向的还是纵向的。
Barn | : | 设置或检索转换所使用的随机线条是横向的还是纵向的。


overlap | Overlap 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Fade ( overlap = fOverlap )
Scripting | object.filters.item('DXImageTransform.Microsoft.Fade').Overlap = fOverlap
取值：
fOverlap : 浮点数(Real)。取值范围为 0.0 - 1.0 。默认值为 1.0 。
说明：
设置或检索在转换进程中源内容和目标内容都被显示的比例。
假如此属性值设为 0.4 ， duration 属性值设为 10 ，则转换会发生下属行为：
  1. 前三秒，源对象开始隐出。
  2. 随后的四秒，源对象完全隐出，新内容同时隐入。
  3. 最后三秒，新内容完全隐入。


Percent 版本：DHTML Object Model　读/写
语法：
Scripting object.filters.item('DXImageTransform.Microsoft. sFilterName ').Percent = iPercent
取值：
iPercent : 字符串(String)。取值范围为 0 - 100 。默认值为 0 ，转换尚未开始。 100 为转换完成。
说明：
设置或检索当前静态滤镜输出在转换进程中所处的点。
此特性可用于使用转换滤镜建立静态滤镜效果。设置其值等于定义了转换进程停止的点。使用转换滤镜建立静态滤镜效果可遵循以下步骤：
  1. 使用转换滤镜的 apply 方法。这将捕获对象内容的初始显示，设置 Percent 特性值为 0 。
  2. 改变对象内容。如 visibility ， innerText ， background-color ， border ，或者其子对象的属性。
  3. 设置转换滤镜的 Percent 特性。即确定你希望的转换进程中某一点。这将捕获到转换进程中在该点处的一张内容图像。
  4. 设置转换滤镜的 Enabled 特性值为 true 。则滤镜作用的对象将依据获取到的图像更新其内容。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。


phase | Phase 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Wave ( phase = iPercentage )
Scripting | object.filters.item('DXImageTransform.Microsoft.Wave').Phase = iPercentage
取值：
iPercentage : 整数值(Integer)。取值范围为 0 - 100 。默认值为 0 。
说明：
设置或检索正弦波开始处的相位偏移。


pixelRadius | PixelRadius 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Blur ( pixelRadius = flRadius )
Scripting | object.filters.item('DXImageTransform.Microsoft.Blur').PixelRadius = flRadius
取值：
flRadius : 浮点数(Float)。默认单位为像素(px)。
取值范围为 1.0 - 100.0 。默认值为 2.0 。当此参数值小于 1.0 时滤镜失去作用。当此参数值大于 100.0 时，此参数使用默认值 2.0 。
说明：
设置或检索模糊效果的作用深度。


positive | Positive 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.DropShadow ( positive = bPositive )
Scripting | object.filters.item('DXImageTransform.Microsoft.DropShadow').Positive = bPositive
取值：
bPositive : 布尔值(Boolean)。true | false
true | : | 默认值。滤镜从对象的非透明像素建立阴影。
false | : | 滤镜从对象的透明像素建立阴影。
说明：
设置或检索滤镜是否从对象的非透明像素建立阴影。假如你有一个透明的对象但想给它建立普通的阴影，设置此参数值为 true。这会让透明对象的阴影在透明区域外，而非在透明区域内。


Rotation版本：DHTML Object Model　读/写
语法：
Scripting object.filters.item('DXImageTransform.Microsoft.BasicImage').Rotation = iRotation
取值：
iRotation : 整数值(Integer)。0 | 1 | 2 | 3
0 | : | 默认值。内容不旋转。
1 | : | 内容旋转90度。
2 | : | 内容旋转180度。
3 | : | 内容旋转270度。
说明：
设置或检索对象内容的旋转。


shadowOpacity | ShadowOpacity 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Blur ( shadowOpacity = fOpacity )
Scripting | object.filters.item('DXImageTransform.Microsoft.Blur').ShadowOpacity = fOpacity
取值：
fOpacity : 可选项。浮点数(Float)。
取值范围为 0.0 - 1.0 。 0.0 为完全透明。 1.0 为完全不透明。默认值为 0.75 。当此参数值不在取值范围内时，此参数使用默认值 0.75 。
说明：
设置或检索在 Blur 滤镜中使用 makeShadow 制作成的阴影的透明度(暗度)。


SizingMethod | SizingMethod 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:FilterTypeImageTransform.Microsoft.Matrix ( SizingMethod = sMethod )
Scripting | object.filters.item('FilterTypeImageTransform.Microsoft.Matrix').SizingMethod = sMethod
取值：
sMethod : 字符串(String)。clip to original | auto expand
clip to original | : | 默认值。容器不改变尺寸。
auto expand | : | 容器改变尺寸以适应目标图像。
说明：
设置或检索容器是否改变尺寸去适应目标图像。


sizingMethod | sizingMethod 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:FilterTypeImageTransform.Microsoft.AlphaImageLoader ( sizingMethod = sMethod )
Scripting | object.filters.item('FilterTypeImageTransform.Microsoft.AlphaImageLoader').sizingMethod = sMethod
取值：
sMethod : 字符串(String)。
crop | : | 剪切图片以适应对象尺寸。
image | : | 默认值。增大或减小对象的尺寸边界以适应图片的尺寸。
scale | : | 缩放图片以适应对象的尺寸边界。
说明：
设置或检索滤镜作用的对象的图片在对象容器边界内的显示方式。


slideStyle | SlideStyle版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Slide ( slideStyle = sStyle )
Scripting | object.filters.item('DXImageTransform.Microsoft.Slide').SlideStyle = sStyle
取值：
sStyle : 字符串(String)。HIDE | PUSH | SWAP
HIDE | : | 默认值。在新内容上抽离旧内容。
PUSH | : | 抽离旧内容时同步同向拉进新内容。
SWAP | : | 在抽离的同时交换新旧内容。
说明：
设置或检索滑条抽离效果的方式。


spokes | spokes版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Wheel ( spokes = iRows )
Scripting | object.filters.item('DXImageTransform.Microsoft.Wheel').spokes = iRows
取值：
iRows : 整数值(Integer)。取值范围为 2 - 20 。默认值为 4 。
说明：
设置或检索风车叶轮数目。


squaresX | SquaresX版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.CheckerBoard ( squaresX = iRows )
Scripting | object.filters.item('DXImageTransform.Microsoft.CheckerBoard').SquaresX = iRows
取值：
iRows : 整数值(Integer)。取值范围为 >=2 。默认值为 12 。任何小于 2 的值都会被转为默认值 12 。
说明：
设置或检索滤镜效果中横向有多少条。


squaresY | SquaresY版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.CheckerBoard ( squaresY = iRows )
Scripting | object.filters.item('DXImageTransform.Microsoft.CheckerBoard').SquaresY = iRows
取值：
iRows : 整数值(Integer)。取值范围为 >=2 。默认值为 10 。任何小于 2 的值都会被转为默认值 10 。
说明：
设置或检索滤镜效果中纵向有多少条。


src | src 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:FilterTypeImageTransform.Microsoft.AlphaImageLoader ( src = sURL )
Scripting | object.filters.item('FilterTypeImageTransform.Microsoft.AlphaImageLoader').src = sURL
取值：
sURL : 字符串(String)。绝对或相对 url 地址。
说明：
使用绝对或相对 url 地址指定背景图像。假如忽略此参数，滤镜将不会作用。
载入的图片会成为对象的显示区域。你可以通过设置 AlphaImageLoader 滤镜的 sizingMethod 属性值缩放或剪切图片。


srcElement版本：DHTML Object Model　读/写
语法：
Scripting event . srcElement = oObject
取值：
oObject : 对象(Element)。无默认值。
说明：
检索激活事件的对象。
此属性在 IE4 中是只读的，在 IE5+ 中是可读写的。


srcFilter版本：DHTML Object Model　读/写
语法：
Scripting event . srcFilter = sSrcFilter
取值：
sSrcFilter : 对象(Element)。无默认值。
说明：
设置或检索激活 onfilterchange 事件的滤镜(Visual Filters and Transitions Reference)对象。
此属性在 IE4 中是只读的，在 IE5+ 中是可读写的。


StartColor 版本：DHTML Object Model　读/写
语法：
Scripting object.filters.item('DXImageTransform.Microsoft.Gradient').StartColor = sColor
取值：
sColor : 整数值(Integer)。 无默认值。取值范围为 0 - 4294967295 。 0 为透明。 4294967295 为不透明白色。当在脚本中使用此特性时，也可以用十六进制格式： 0xAARRGGBB 。
说明：
设置或检索色彩渐变的开始颜色。


startColorStr | StartColorStr 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Gradient ( startColorStr = iWidth )
Scripting | object.filters.item('DXImageTransform.Microsoft.Gradient').StartColorStr = iWidth
取值：
iWidth : 字符串(String)。32位 ARGB 格式色彩值。
其格式为 #AARRGGBB 。 AA 、 RR 、 GG 、 BB 为十六进制正整数。取值范围为 00 - FF 。 RR 指定红色值， GG 指定绿色值， BB 指定蓝色值。 AA 指定透明度。 00 是完全透明。 FF 是完全不透明。超出取值范围的值将被恢复为默认值。
取值范围为 #FF000000 - #FFFFFFFF 。默认值为 #FF0000FF 。不透明蓝色。
说明：
设置或检索色彩渐变的开始颜色和透明度。


startX | StartX 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Alpha ( startX = iPercent )
Scripting | object.filters.item('DXImageTransform.Microsoft.Alpha').StartX = iPercent
取值：
iPercent : 整数值(Integer)。其数值作为对象宽度的百分比值处理。默认值为 0 。
说明：
设置或检索 Alpha 滤镜透明渐变开始点的水平坐标。仅当 style 属性值设置为 1 ，即渐变样式为线性(linear)渐变时，此属性才会发生作用。


startY | StartY 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Alpha ( startY = iPercent )
Scripting | object.filters.item('DXImageTransform.Microsoft.Alpha').StartY = iPercent
取值：
iPercent : 整数值(Integer)。其数值作为对象高度的百分比值处理。默认值为 0 。
说明：
设置或检索 Alpha 滤镜透明渐变开始点的垂直坐标。仅当 style 属性值设置为 1 ，即渐变样式为线性(linear)渐变时，此属性才会发生作用。


status 版本：DHTML Object Model　 只读
语法：
Scripting iStatus = object.filters.item('DXImageTransform.Microsoft. sFilterName ').status
取值：
iStatus : 整数值(Integer)。0 | 1 | 2
0 | : | 转换停止( stop )。
1 | : | 转换被应用( apply )。
2 | : | 转换在进行( play )。
说明：
检索转换的当前状态。


strength | Strength版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft. sFilterName ( strength = iDistance )
Scripting | object.filters.item('DXImageTransform.Microsoft. sFilterName ').Strength = iDistance
取值：
iDistance : 整数值(Integer)。单位为像素( px )。 此属性无默认值。以下为例外:
MotionBlur | : | 5
Glow | : | 5
Wave | : | 1
说明：
设置或检索以对象为基准的在运动方向上的向外扩散距离。
此属性作用于下列滤镜有不同的取值范围:
MotionBlur | : | >=0
Glow | : | 1 - 255
Wave | :  | >=1


stretchStyle | StretchStyle 版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Stretch ( stretchStyle = sStyle )
Scripting | object.filters.item('DXImageTransform.Microsoft.Stretch').StretchStyle = sStyle
取值：
sStyle : 字符串(String)。SPIN | HIDE | PUSH
SPIN | : | 默认值。在旧内容上自中心向左右两边拉伸新内容。
HIDE | : | 在旧内容上自左向右拉伸(缩)新内容。
PUSH | : | 自左向右拉伸新内容近来同时挤压旧内容出去。这种转换方式的视觉效果类似立方体从一面转到另一面。
说明：
设置或检索拉伸变形转换的方式。


style | Style版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.Alpha ( style = iStyle )
Scripting | object.filters.item('DXImageTransform.Microsoft.Alpha').Style = iStyle
取值：
iStyle : 整数值(Integer)。0 | 1 | 2 | 3
0 | : | 默认值。整体透明度。将 Opacity 值均匀的作用于对象。
1 | : | 线性渐变透明度。从由 StartX 和 StartY 决定的点，由 Opacity 决定的透明度开始，到由 FinishX 和 FinishY 决定的点，由 FinishOpacity决定的透明度结束。
2 | : | 圆形放射渐变透明度。圆形放射区域的圆心为对象的中心，圆周到与对象的边相切为止。透明渐变由圆心开始，到圆周结束。开始透明度由 Opacity 决定，结束透明度由 FinishOpacity 决定。
3 | : | 矩形放射渐变透明度。由对象的边开始，到对象的中心结束。开始透明度由 Opacity 决定，结束透明度由 FinishOpacity 决定。
说明：
设置或检索透明渐变的样式。


transition | Transition版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.RevealTrans ( transition = iTransitionType )
Scripting | object.filters.item('DXImageTransform.Microsoft.RevealTrans').Transition = iTransitionType
取值：
iTransitionType : 整数值(Integer)。无默认值。
0 | : | 矩形收缩转换。
1 | : | 矩形扩张转换。
2 | : | 圆形收缩转换。
3 | : | 圆形扩张转换。
4 | : | 向上擦除。
5 | : | 向下擦除。
6 | : | 向右擦除。
7 | : | 向左擦除。
8 | : | 纵向百叶窗转换。
9 | : | 横向百叶窗转换。
10 | : | 国际象棋棋盘横向转换。
11 | : | 国际象棋棋盘纵向转换。
12 | : | 随机杂点干扰转换。
13 | : | 左右关门效果转换。
14 | : | 左右开门效果转换。
15 | : | 上下关门效果转换。
16 | : | 上下开门效果转换。
17 | : | 从右上角到左下角的锯齿边覆盖效果转换。
18 | : | 从右下角到左上角的锯齿边覆盖效果转换。
19 | : | 从左上角到右下角的锯齿边覆盖效果转换。
20 | : | 从左下角到右上角的锯齿边覆盖效果转换。
21 | : | 随机横线条转换。
22 | : | 随机竖线条转换。
23 | : | 随机使用上面可能的值转换。
说明：
设置或检索转换所使用的方式。仅仅当系统显示色盘设置为256种以上颜色时此属性才可被正确应用。


type版本：DOM1　读/写
语法：
Scripting event . type = sType
取值：
sType : 字符串(String)。无默认值。
说明：
检索事件对象的名称。
此属性在 IE4 中是只读的，在 IE5+ 中是可读写的。
此属性返回的事件名称没有 on 前缀。例如， onclick 事件的此属性返回的是 click 。


wipeStyle | WipeStyle版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.RadialWipe ( wipeStyle = sStyle )
Scripting | object.filters.item('DXImageTransform.Microsoft.RadialWipe').WipeStyle = sStyle
取值：
sStyle : 字符串(String)。CLOCK | WEDGE | RADIAL
CLOCK | : | 默认值。围绕对象的中心，自上方开始，顺时针旋转擦除。
WEDGE | : | 围绕对象的中心，自上方开始，同时向两边旋转擦除。
RADIAL | : | 以对象的左上角为圆心旋转擦除。
说明：
设置或检索转换所使用的擦除方式。


WipeStyle版本：DHTML Object Model　读/写
语法：
Scripting object.filters.item('DXImageTransform.Microsoft.GradientWipe').WipeStyle = iStyle
取值：
iStyle : 字符串(String)。0 | 1
0 | : | 默认值。转换在水平方向上自左至右。
1 | : | 转换在垂直方向上自上至下。
说明：
设置或检索渐隐滚动条的方向。


XRay | XRay版本：DHTML Object Model　读/写
语法：
CSS | filter : progid:DXImageTransform.Microsoft.BasicImage ( XRay = bXRay )
Scripting | object.filters.item('DXImageTransform.Microsoft.BasicImage').XRay = bXRay
取值：
bXRay : 布尔值(Boolean)。0 | 1
1 | : | 以X光效果显示对象内容。
0 | : | 默认值。正常显示对象内容。
说明：
设置或检索是否通过红、绿均衡补偿的方法以X光效果显示对象内容。


onfilterchange版本：DHTML Object Model
语法：
HTML | <element onfilterchange = " Scripts ">
HTML | <script for = object event = onfilterchange> Scripts </script>
Scripting | object.onfilterchange = Handle
Scripting | function object.onfilterchange () { Scripts }
信息：
事件冒泡(Bubbles) | : | 否
可被取消(Cancels) | : | 否
激活条件(To invoke) | : | 滤镜(Visual Filters and Transitions)状态改变时。
默认动作(Default action) | : | 发出滤镜状态改变的信号。
说明：
当滤镜(Visual Filters and Transitions)状态改变或完成时激发的事件。


Appendix　附 录

  1. Color Table 颜色表


DHTMLET(TM)

Introduction手册简介
手册说明：
本手册针对的是已有一定网页设计制作经验的读者。其目的是提供完整清晰的样式表内容的快速索引及进阶帮助。所以对于网页制作和样式表的基础知识，仅简单介绍，恕不赘述。