Android Studio 使用他人的项目-SDK 版本不对

作者:vkvi 来源:千一网络(原创) 日期:2017-3-12

他人的 SDK 版本和我们的可能不一样,拿到我们机子上就会出错。

SDK 版本不对非常好解决,只需要按它的提示点击,安装需要的就可以了。

这也是最稳妥的方法。

SDK platform 缺失

它只会安装对应版本 SDK 的 platform 部分,所以不算很大,速度也算快。

或者我们也可以使用 SDK 文件夹下面的 SDK Manager.exe 来安装。

还有一种办法,改 compileSdkVersion,但不保证这一定会成功。

一种改法是改对应 Module 下面的 build.gradle 文件:

compileSdkVersion

另一种是按 Ctrl + Alt + Shift + S,在对话框中改 Compile Sdk Version。但是由于本身就缺少对应版本的 Sdk,所以左边 Modules 不一定能够正确显示(比如我就遇到一个 Project 下有两个 Module,它没有识别到 Module,而是把 Project 当作 Module。下图中的 Module 是正确的)。

compileSdkVersion

 

你前面那位网友看了:多步 OLEDB 操作产生错误,没有工作被完成

▲▲▲嘿,欢迎转载传播本站原创文章,尽量保留来源噢。▲▲▲

文章评论
标题:必填
内容:
本站永远终止与捏造“罪名”不支付广告费的某度联盟合作。
vkvi
vkvi

作者简介: vkvi,致力于 .NET Web 开发、移动开发的技术推广,在 .NET、SQL Server、Windows Server 等方面有深入研究和丰富经验,10 年间共计撰写文章 4000 余篇。 主持金融、国土、农业、电商等多个行业项目执行, 推行“技术提升生产力、人心决定成功率”的管理理论。 联系他